$re = '/(?:\[|\G(?!^))[^]\s]*\K\s+/';
$str = '[Word1 Word2 Word3] word 4 word5 [ word6]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;