using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[|\G(?!^))[^]\s]*\K\s+";
string substitution = @"";
string input = @"[Word1 Word2 Word3] word 4 word5 [ word6]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}