re = /(?:\[|\G(?!^))[^]\s]*\K\s+/
str = '[Word1 Word2 Word3] word 4 word5 [ word6]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result