using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=строка1).*(?<=строка1)(?'res'.*?)(?=строка2)";
string input = @"строка1 плваопо валпваоп строка1 ьопау лдпаа строка2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}