const regex = /(?<=строка1).*(?<=строка1)(?'res'.*?)(?=строка2)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=строка1).*(?<=строка1)(?\'res\'.*?)(?=строка2)', 'gm')
const str = `строка1 плваопо валпваоп строка1 ьопау лдпаа строка2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}