$re = '/(?<=строка1).*(?<=строка1)(?\'res\'.*?)(?=строка2)/m';
$str = 'строка1 плваопо валпваоп строка1 ьопау лдпаа строка2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);