#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>22)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>5X)(?P<sep_2>/|=)(?P<surface_coating>|)(?P<seal_material>V|)(?P<special_version>SO40|SO60|)(?P<additional_details>(.|[0-9])*)$"
Local $sString = "Z2S22-1-5X=" & @CRLF & _
"Z2S22A1-5X/V" & @CRLF & _
"Z2S22-1-5X/" & @CRLF & _
"Z2S22-2-5X/" & @CRLF & _
"Z2S22A1-5X/" & @CRLF & _
"Z2S22B1-5X/" & @CRLF & _
"Z2S22-4-5X/" & @CRLF & _
"Z2S22-1-5X/V" & @CRLF & _
"Z2S22B2-5X/" & @CRLF & _
"Z2S22-3-5X/" & @CRLF & _
"Z2S22A2-5X/" & @CRLF & _
"Z2S22-3-5X/V" & @CRLF & _
"Z2S22A3-5X/" & @CRLF & _
"Z2S22B4-5X/" & @CRLF & _
"Z2S22A2-5X/SO40" & @CRLF & _
"Z2S22A4-5X/" & @CRLF & _
"Z2S22-2-5X/V" & @CRLF & _
"Z2S22B3-5X/" & @CRLF & _
"Z2S22B1-5X/V" & @CRLF & _
"Z2S22B1-5X/SO40" & @CRLF & _
"Z2S22A1-5X/SO60" & @CRLF & _
"Z2S22B1-5X/SO60" & @CRLF & _
"Z2S22A1-5X/SO40" & @CRLF & _
"Z2S22A2-5X/V" & @CRLF & _
"Z2S22B2-5X/V" & @CRLF & _
"Z2S22A4-5X/SO40" & @CRLF & _
"Z2S22A3-5X/V" & @CRLF & _
"Z2S22B1-5X/VSO60" & @CRLF & _
"Z2S22B1-5X/VSO40" & @CRLF & _
"Z2S22-4-5X/V" & @CRLF & _
"Z2S22B3-5X/SO40" & @CRLF & _
"Z2S22A1-5X=SO60" & @CRLF & _
"Z2S22B3-5X/V" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")