import re
regex = re.compile(r"^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>22)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>5X)(?P<sep_2>/|=)(?P<surface_coating>|)(?P<seal_material>V|)(?P<special_version>SO40|SO60|)(?P<additional_details>(.|[0-9])*)$", flags=re.MULTILINE)
test_str = ("Z2S22-1-5X=\n"
"Z2S22A1-5X/V\n"
"Z2S22-1-5X/\n"
"Z2S22-2-5X/\n"
"Z2S22A1-5X/\n"
"Z2S22B1-5X/\n"
"Z2S22-4-5X/\n"
"Z2S22-1-5X/V\n"
"Z2S22B2-5X/\n"
"Z2S22-3-5X/\n"
"Z2S22A2-5X/\n"
"Z2S22-3-5X/V\n"
"Z2S22A3-5X/\n"
"Z2S22B4-5X/\n"
"Z2S22A2-5X/SO40\n"
"Z2S22A4-5X/\n"
"Z2S22-2-5X/V\n"
"Z2S22B3-5X/\n"
"Z2S22B1-5X/V\n"
"Z2S22B1-5X/SO40\n"
"Z2S22A1-5X/SO60\n"
"Z2S22B1-5X/SO60\n"
"Z2S22A1-5X/SO40\n"
"Z2S22A2-5X/V\n"
"Z2S22B2-5X/V\n"
"Z2S22A4-5X/SO40\n"
"Z2S22A3-5X/V\n"
"Z2S22B1-5X/VSO60\n"
"Z2S22B1-5X/VSO40\n"
"Z2S22-4-5X/V\n"
"Z2S22B3-5X/SO40\n"
"Z2S22A1-5X=SO60\n"
"Z2S22B3-5X/V\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")