import Foundation
let pattern = #"^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>22)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>5X)(?P<sep_2>/|=)(?P<surface_coating>|)(?P<seal_material>V|)(?P<special_version>SO40|SO60|)(?P<additional_details>(.|[0-9])*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Z2S22-1-5X=
Z2S22A1-5X/V
Z2S22-1-5X/
Z2S22-2-5X/
Z2S22A1-5X/
Z2S22B1-5X/
Z2S22-4-5X/
Z2S22-1-5X/V
Z2S22B2-5X/
Z2S22-3-5X/
Z2S22A2-5X/
Z2S22-3-5X/V
Z2S22A3-5X/
Z2S22B4-5X/
Z2S22A2-5X/SO40
Z2S22A4-5X/
Z2S22-2-5X/V
Z2S22B3-5X/
Z2S22B1-5X/V
Z2S22B1-5X/SO40
Z2S22A1-5X/SO60
Z2S22B1-5X/SO60
Z2S22A1-5X/SO40
Z2S22A2-5X/V
Z2S22B2-5X/V
Z2S22A4-5X/SO40
Z2S22A3-5X/V
Z2S22B1-5X/VSO60
Z2S22B1-5X/VSO40
Z2S22-4-5X/V
Z2S22B3-5X/SO40
Z2S22A1-5X=SO60
Z2S22B3-5X/V
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)