using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>22)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>5X)(?P<sep_2>/|=)(?P<surface_coating>|)(?P<seal_material>V|)(?P<special_version>SO40|SO60|)(?P<additional_details>(.|[0-9])*)$";
string input = @"Z2S22-1-5X=
Z2S22A1-5X/V
Z2S22-1-5X/
Z2S22-2-5X/
Z2S22A1-5X/
Z2S22B1-5X/
Z2S22-4-5X/
Z2S22-1-5X/V
Z2S22B2-5X/
Z2S22-3-5X/
Z2S22A2-5X/
Z2S22-3-5X/V
Z2S22A3-5X/
Z2S22B4-5X/
Z2S22A2-5X/SO40
Z2S22A4-5X/
Z2S22-2-5X/V
Z2S22B3-5X/
Z2S22B1-5X/V
Z2S22B1-5X/SO40
Z2S22A1-5X/SO60
Z2S22B1-5X/SO60
Z2S22A1-5X/SO40
Z2S22A2-5X/V
Z2S22B2-5X/V
Z2S22A4-5X/SO40
Z2S22A3-5X/V
Z2S22B1-5X/VSO60
Z2S22B1-5X/VSO40
Z2S22-4-5X/V
Z2S22B3-5X/SO40
Z2S22A1-5X=SO60
Z2S22B3-5X/V
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}