$re = '/^(?:[^_]*_){7}([^_]*)/m';
$str = 'abc_fjs_dja_sja_dj_sadjasdksa_sdjakd_match_fsja_fsdk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);