re = /^(?:[^_]*_){7}([^_]*)/m
str = 'abc_fjs_dja_sja_dj_sadjasdksa_sdjakd_match_fsja_fsdk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end