#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mis)\{if\s{1}(.+?)\}\n(((?R)|.*?)+)\{\/if\}"
Local $sString = "{if $name == 'Tree'}" & @CRLF & _
" Hey, this is a Tree!" & @CRLF & _
"{/if}" & @CRLF & _
"" & @CRLF & _
"{if $name == 'Example'}" & @CRLF & _
" {if $number == '1'}" & @CRLF & _
" Hey, this is an Example with the number 1" & @CRLF & _
" {/if}" & @CRLF & _
"{/if}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")