package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)\{if\s{1}(.+?)\}\n(((?R)|.*?)+)\{\/if\}`)
var str = `{if $name == 'Tree'}
Hey, this is a Tree!
{/if}
{if $name == 'Example'}
{if $number == '1'}
Hey, this is an Example with the number 1
{/if}
{/if}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}