import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "г.([А-Яа-я\\s\\-]+)[, ]?(([ ]?)+(ул|пр|пер|пр-т|б-р|бул)\\s?\\.?)([\\-А-Яа-я \\.]+)[, ](.+)";
final String string = " г.Минск ,пр-т. Победителей, 63/1-2, пом.131";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}