use strict;
my $str = ' г.Минск ,пр-т. Победителей, 63/1-2, пом.131';
my $regex = qr/г.([А-Яа-я\s\-]+)[, ]?(([ ]?)+(ул|пр|пер|пр-т|б-р|бул)\s?\.?)([\-А-Яа-я \.]+)[, ](.+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}