// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"г.([А-Яа-я\s\-]+)[, ]?(([ ]?)+(ул|пр|пер|пр-т|б-р|бул)\s?\.?)([\-А-Яа-я \.]+)[, ](.+)").unwrap();
let string = " г.Минск ,пр-т. Победителей, 63/1-2, пом.131";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}