const regex = new RegExp('^(?=(?:[^0-9]*[0-9]){4})[0-9A-Z.-]+$', 'gm')
const str = `ART-4.5-11
ART5411
76543
aRT-4!5-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}