re = /^(?=(?:[^0-9]*[0-9]){4})[0-9A-Z.-]+$/m
str = 'ART-4.5-11
ART5411
76543
aRT-4!5-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end