$re = '/^(?=(?:[^0-9]*[0-9]){4})[0-9A-Z.-]+$/m';
$str = 'ART-4.5-11
ART5411
76543
aRT-4!5-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);