import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!0*\\.0+$)\\d*(?:\\.\\d+)?$";
final String string = "0.07\n"
+ "0.0\n"
+ "20\n"
+ "0.00007\n"
+ "0.0000\n"
+ ".007\n"
+ "5.00\n"
+ "4.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}