import re
regex = re.compile(r"^(?!0*\.0+$)\d*(?:\.\d+)?$", flags=re.MULTILINE)
test_str = ("0.07\n"
"0.0\n"
"20\n"
"0.00007\n"
"0.0000\n"
".007\n"
"5.00\n"
"4.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")