$re = '/^(?!0*\.0+$)\d*(?:\.\d+)?$/m';
$str = '0.07
0.0
20
0.00007
0.0000
.007
5.00
4.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);