#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(jan|fever)eiro|ma(rç|i)o|abril|ju[ln]ho|agosto|((set|nov|dez)em|outu)bro"
Local $sString = "janeiro" & @CRLF & _
"fevereiro" & @CRLF & _
"março" & @CRLF & _
"abril" & @CRLF & _
"maio" & @CRLF & _
"junho" & @CRLF & _
"julho" & @CRLF & _
"agosto" & @CRLF & _
"setembro" & @CRLF & _
"outubro" & @CRLF & _
"novembro" & @CRLF & _
"dezembro" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")