const regex = /(jan|fever)eiro|ma(rç|i)o|abril|ju[ln]ho|agosto|((set|nov|dez)em|outu)bro/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(jan|fever)eiro|ma(rç|i)o|abril|ju[ln]ho|agosto|((set|nov|dez)em|outu)bro', 'gm')
const str = `janeiro
fevereiro
março
abril
maio
junho
julho
agosto
setembro
outubro
novembro
dezembro
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}