import re
regex = re.compile(r"(jan|fever)eiro|ma(rç|i)o|abril|ju[ln]ho|agosto|((set|nov|dez)em|outu)bro", flags=re.MULTILINE)
test_str = ("janeiro\n"
"fevereiro\n"
"março\n"
"abril\n"
"maio\n"
"junho\n"
"julho\n"
"agosto\n"
"setembro\n"
"outubro\n"
"novembro\n"
"dezembro\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")