$re = '/(jan|fever)eiro|ma(rç|i)o|abril|ju[ln]ho|agosto|((set|nov|dez)em|outu)bro/m';
$str = 'janeiro
fevereiro
março
abril
maio
junho
julho
agosto
setembro
outubro
novembro
dezembro
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);