using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([-+,0-9.]+)";
string input = @"abc - false
123 - true
abc,12 - false
123,12 - true
-123,12 - true
-123 - true
+123,12.18 - true
123,12.12 - true
-123.19 - true
+123,12.18 - true
123,12.12 - true
-123,000,000.19 - true";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}