$re = '/^([-+,0-9.]+)/m';
$str = 'abc - false
123 - true
abc,12 - false
123,12 - true
-123,12 - true
-123 - true
+123,12.18 - true
123,12.12 - true
-123.19 - true
+123,12.18 - true
123,12.12 - true
-123,000,000.19 - true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);