re = /^([-+,0-9.]+)/m
str = 'abc - false
123 - true
abc,12 - false
123,12 - true
-123,12 - true
-123 - true
+123,12.18 - true
123,12.12 - true
-123.19 - true
+123,12.18 - true
123,12.12 - true
-123,000,000.19 - true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end