package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([-+,0-9.]+)`)
var str = `abc - false
123 - true
abc,12 - false
123,12 - true
-123,12 - true
-123 - true
+123,12.18 - true
123,12.12 - true
-123.19 - true
+123,12.18 - true
123,12.12 - true
-123,000,000.19 - true`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}