#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\w+)\b(?<!\b\1\b.*\b\1\b)(?:(?!\b\1\b).)*?\b\1\b(?!.*\b\1\b)"
Local $sString = "apple banana pineapple" & @CRLF & _
"apple banana apple pineapple" & @CRLF & _
"apple banana banana pineapple" & @CRLF & _
"apple banana apple pineapple apple" & @CRLF & _
"apple banana apple banana" & @CRLF & _
"apple banana banana apple pineapple apple"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")