re = /\b(\w+)\b(?<!\b\1\b.*\b\1\b)(?:(?!\b\1\b).)*?\b\1\b(?!.*\b\1\b)/m
str = 'apple banana pineapple
apple banana apple pineapple
apple banana banana pineapple
apple banana apple pineapple apple
apple banana apple banana
apple banana banana apple pineapple apple'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end