using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w+)\b(?<!\b\1\b.*\b\1\b)(?:(?!\b\1\b).)*?\b\1\b(?!.*\b\1\b)";
string input = @"apple banana pineapple
apple banana apple pineapple
apple banana banana pineapple
apple banana apple pineapple apple
apple banana apple banana
apple banana banana apple pineapple apple";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}