import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w+)\\b(?<!\\b\\1\\b.*\\b\\1\\b)(?:(?!\\b\\1\\b).)*?\\b\\1\\b(?!.*\\b\\1\\b)";
final String string = "apple banana pineapple\n"
+ "apple banana apple pineapple\n"
+ "apple banana banana pineapple\n"
+ "apple banana apple pineapple apple\n"
+ "apple banana apple banana\n"
+ "apple banana banana apple pineapple apple";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}