#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:[a-z]+\b.*?\b[A-Z]+|[A-Z]+\b.*?\b[a-z]+)\b"
Local $sString = "hello...hello" & @CRLF & _
"hello...HELLO" & @CRLF & _
"HELLO...hello" & @CRLF & _
"HELLO...HELLO"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")