package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[a-z]+\b.*?\b[A-Z]+|[A-Z]+\b.*?\b[a-z]+)\b`)
var str = `hello...hello
hello...HELLO
HELLO...hello
HELLO...HELLO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}