using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[a-z]+\b.*?\b[A-Z]+|[A-Z]+\b.*?\b[a-z]+)\b";
string input = @"hello...hello
hello...HELLO
HELLO...hello
HELLO...HELLO";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}