$re = '/\b(?:[a-z]+\b.*?\b[A-Z]+|[A-Z]+\b.*?\b[a-z]+)\b/m';
$str = 'hello...hello
hello...HELLO
HELLO...hello
HELLO...HELLO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);