const regex = /^(((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.?){4})\/(0?[1-9]|[12][0-9]|3[01])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\\.?){4})\\\/(0?[1-9]|[12][0-9]|3[01])$', 'gm')
const str = `64.33.232.212
64.33.232.210/31`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}