$re = '/^(((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.?){4})\/(0?[1-9]|[12][0-9]|3[01])$/m';
$str = '64.33.232.212
64.33.232.210/31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);