// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.?){4})\/(0?[1-9]|[12][0-9]|3[01])$").unwrap();
let string = "64.33.232.212
64.33.232.210/31";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}