#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\w+\s\w+\s\w+\s)(\d{3})(.*)"
Local $sString = "Bach 2000 v03CD15 045 - Cantatas BWV 147-149" & @CRLF & _
"Bach 2000 v03CD05 1 - Cantata, BWV 112" & @CRLF & _
"Bach 2000 v03CD05 10 - Cantata, BWV 113" & @CRLF & _
"Bach 2000 v03CD1 1 - Cantata, BWV 100" & @CRLF & _
"Bach 2000 v03CD1 10 - Cantata, BWV 101" & @CRLF & _
"Bach 2000 v03CD1 020 - Cantata, BWV 102" & @CRLF & _
"Bach 2000 v03CD10 10 - Cantata, BWV 129"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)