$re = '/(^\w+\s\w+\s\w+\s)(\d{3})(.*)/m';
$str = 'Bach 2000 v03CD15 045 - Cantatas BWV 147-149
Bach 2000 v03CD05 1 - Cantata, BWV 112
Bach 2000 v03CD05 10 - Cantata, BWV 113
Bach 2000 v03CD1 1 - Cantata, BWV 100
Bach 2000 v03CD1 10 - Cantata, BWV 101
Bach 2000 v03CD1 020 - Cantata, BWV 102
Bach 2000 v03CD10 10 - Cantata, BWV 129';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;