# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*)\n(\d*)/My name is $1 and I am $2 years old./gm;t' <<< "Banana
67"