// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*)\n(\d*)").unwrap();
let string = "Banana
67";
let substitution = "My name is $1 and I am $2 years old.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}