import re
regex = re.compile(r"(.*)\n(\d*)", flags=re.MULTILINE)
test_str = ("Banana\n"
"67")
subst = "My name is $1 and I am $2 years old."
result = regex.sub(subst, test_str)
if result:
print(result)