package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(category \b(\w+)\b )((\b\w+\b)+)`)
var str = `category fruits pear orange
category meat beef duck`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}