$re = '/(category \b(\w+)\b )((\b\w+\b)+)/is';
$str = 'category fruits pear orange
category meat beef duck';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);