using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ДАНИ)(?:Л|ЛУ|ЛА|ЛОМ|ЛЕ|)
";
string input = @"ДАНИЛУ
ДАНИЛА
С ДАНИЛОМ
О ДАНИЛЕ
ДАНИЛ
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}